Friday, October 24, 2014

Ping

PING (Packet Internet Groper):

Ping is Member of iputils package.

[root@UnixBabuForun ~]# rpm -qf `which ping`
iputils-20071127-16.el6.i686
[root@UnixBabuForun ~]# rpm -ql iputils | grep "ping"

/bin/ping

Ping is having setuid by default and hence each user can be able to execute ping.

[root@UnixBabuForun ~]# ls -l /bin/ping
-rwsr-xr-x. 1 root root 36892 Mar 22  2011 /bin/ping



Send 3 requests to target with ping

[root@UnixBabuForun ~]# ping -c 3 192.168.79.135
PING 192.168.79.135 (192.168.79.135) 56(84) bytes of data.
64 bytes from 192.168.79.135: icmp_seq=1 ttl=64 time=1.30 ms
64 bytes from 192.168.79.135: icmp_seq=2 ttl=64 time=0.505 ms
64 bytes from 192.168.79.135: icmp_seq=3 ttl=64 time=0.441 ms

--- 192.168.79.135 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 0.441/0.749/1.301/0.391 ms

If the host is running with more then 2 ips, then we can use -I option to pass the ipaddress from which the ping test needs to be done.

[root@UnixBabuForun ~]# ping -I 192.168.79.130  192.168.79.135
PING 192.168.79.135 (192.168.79.135) from 192.168.79.130 : 56(84) bytes of data.
64 bytes from 192.168.79.135: icmp_seq=1 ttl=64 time=0.240 ms
64 bytes from 192.168.79.135: icmp_seq=2 ttl=64 time=0.279 ms
^C
--- 192.168.79.135 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1534ms
rtt min/avg/max/mdev = 0.240/0.259/0.279/0.025 ms

64 bytes is the default packet size, if you want to change the packet size use option s with ping command. here i will use 32 bytes, but it will be overhead  by 8 bytes. so it will be 40 bytes.

[root@UnixBabuForun ~]# ping -s 48 192.168.79.135
PING 192.168.79.135 (192.168.79.135) 48(76) bytes of data.
56 bytes from 192.168.79.135: icmp_seq=1 ttl=64 time=0.218 ms
56 bytes from 192.168.79.135: icmp_seq=2 ttl=64 time=0.438 ms
^C
--- 192.168.79.135 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1393ms
rtt min/avg/max/mdev = 0.218/0.328/0.438/0.110 ms

Ping will send the packets in 1sec intervel by default. we can custamize this intervel by using -i option.

[root@UnixBabuForun ~]#  ping -i 2 192.168.79.135
PING 192.168.79.135 (192.168.79.135) 56(84) bytes of data.
64 bytes from 192.168.79.135: icmp_seq=1 ttl=64 time=0.180 ms
64 bytes from 192.168.79.135: icmp_seq=2 ttl=64 time=0.483 ms
64 bytes from 192.168.79.135: icmp_seq=3 ttl=64 time=1.06 ms
^C
--- 192.168.79.135 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 4104ms
rtt min/avg/max/mdev = 0.180/0.577/1.069/0.369 ms



Wednesday, February 19, 2014

Any More Releases of Solaris 10

www.unixbabuforum.inThe last release of Solaris 10 was 01/13 (u11). Does anybody know if 
there will any more releases of Solaris 10 ? 


www.unixbabuforum.inIt looks like Solaris 10 1/13 (u11) is the last update to Solaris 10.

www.unixbabuforum.inYou have latest releases on 
Soalris 11

Issue With the ALOM Network Settings

www.unixbabuforum.inI have SUN Fire T-2000 Server, we have facing the issue with the network at 
the ALOM level. 
I tried to set the network settings at SC level, but no luck it's not saving 
and I tried with resetsc once done with that network settings. 

I am using below commands at sc level. 
setsc ip_addr 10.250.150.51 
setsc ip_netmask 255.255.255.0 
setsc ip_gateway 10.250.150.22 
setsc ip_connection ssh 
resetsc 


netsc_dhcp true 

We are not using any dhcp. Do I try with below option? Please suggest. 
-->netsc_dhcp false 

Recent Change: DIMMs has been replaced recently in this month. 


www.unixbabuforum.inDoes the sc user you have been logging in as have permissions to reset 
the sc variables? (That user likely needs "administrative" 
permissions.) What happens when you run "showsc" after your attempts 
to enable SSH with a designated address (netmask, gateway)? (DHCP is 
the default setting, so it's apparent that your variable settings are 
not taking effect.) 

www.unixbabuforum.inUse:
Setsc netsc_dhcp false 
Setsc daig-level max 

Resetsc 

www.unixbabuforum.inT-2000 uses ILOM for light out management and it looks like you have an alom user on it. 

You need to set "netsc_dhcp false" since you are providing static IP. 
Also you need to specify 
At SC "netsc_commit true" and then 
Do "resetsc" 
For the changes to take effect.

cdrom Not Appearing After Eject Command

www.unixbabuforum.inI have used "eject" command on solaris 10 which 
I have installed in vmware under Win 7. After eject command , it 
stops showing the cd-rom . I tried to stop/start the vold daemon to 
fix this but did not work .Is there any command using which I can get 
cd-rom detected without restarting solaris 10 OS ? 

www.unixbabuforum.inI would do a "df" to check make sure it is not mounted. Kill vold, then 
manually eject CD using button on CD . The CD might also have a small 
hole the you can put paper clip in to manually eject. 
www.unixbabuforum.intest with "umount" command and eject CD 

Persistent IP Address to Be Assign to Loopback

www.unixbabuforum.inWe need the information on configuring persistent IP address on Loopback interface which is required for DSR (Direct server return) configuration. 

We have base of Solaris 11 with Solaris 10 Branded zones. 

Application deployed on Solaris 10 branded zones. 

www.unixbabuforum.inifconfig lo0 addif 10.10.10.10/32 up 

adds the next logical interface on the specified interface 

ifconfig -a 

shows it 

ifconfig lo0 removeif 10.10.10.10 

removes the logical interface from the specified interface

Reset all nvram Config Param to Default

www.unixbabuforum.inHi, 
After reset all nvram config param to default by the following command on Open Boot prom (OBP) and reset sunfire v240, the os will not load and I do not see anything on the monitor ! 

ok set-defaults 
ok setenv security-mode full 
ok reset-all 

www.unixbabuforum.inhe firmware password issue means that the OBP (NVRAM) variable for 
security-mode is set to something like 'command' instead of 'none'. If 
don't know of a password that's set you will need to return the SC/OBP 
on the server to a default configuration to get out of this scenario. 
One thing, if you type boot at the prompt you are seeing does the server 
boot up to the OS? If it does you can log in as root and then run the 
command eeprom security-mode=none from the shell prompt. That will 
remove the firmware password being prompted for on server reboots. 

Another question, if you type the sequence #. at your serial console do 
you get put in to the SC shell? You should get the sc> prompt if it 
works. If you can get to the SC shell you can type the command; 

sc> setdefaults (answer Y to the message are you sure you want to reset 
SC configuration) 
sc> resetsc 

The SC would then reset and return to OBP without the firmware password. 
You can then look to set the OBP variables again as required. 

www.unixbabuforum.inSounds like your output may be directed to the serail port (ttyA) 
following the default OBP settings being invoked. Connect a cross-over 
cable to ttyA using laptop or dumb terminal (usual term settings of 
9600, 8, no parity, 1 stop bit). Once you get output you may need to 
send a break as system may be trying to boot from the network also. 

You will need to check the boot-device, diag-device and diag-switch? 
settings are correct. You may need to set diag-device to disk, 
diag-switch? to false and boot-device to your required boot disk from 
the devalias output at OBP. Then do a reset-all to commit the settings. 
If output had been directed to ttyA you'll need to set output-device and 
input-device in OBP to your required variables



Configuring Jumpstart in Solaris 10 On Vmware

www.unixbabuforum.in.I am using solaris 10 on vmware worksation installed on 
win 7 on my laptop. 
I have installed two instances of solaris 10 on vmware which are 
networked with each other. I want to know if I can configure and 
install jumpstart on solaris 10 using this type of configuration and 
then install other client machine automatically by that jumpstart 
server 

www.unixbabuforum.inIt should work, when networking is configured in a way, so that broadcasts are also passed to the VM as the communication is initiated by broadcasts. It will work only for Solaris 10, as Solaris 11 uses an entirely new remote installation process. 

 
Design by BABU | Dedicated to grandfather | welcome to BABU-UNIX-FORUM