Sunday, June 10, 2012

Unable to login to rsc

1)When i boot the server with rsc hardware inserted ... i'm directly getting the login/password prompt .... which are unknown . 
2)When removed the rsc card from the server i'm able to get the server up.But i'm unable to get my server up with the card inserted as i'm not aware of the username/password. 
3)Tried with redirecting the input/output to ttya serial and inserted the rsc and rebooted the box....but still the same response. 
Is there any way where i can re-configure the rsc or break the rsc user acount
how did you changed the input and ouput device ? 
if you don't have the password for RSC the best workaround is turn the keyswitch on your server to full diagnostics mode , and plug your serial cable to ttya , because on diag mode it will dump output to ttya by default . 

once on ok prompt , change the input-device and output device to ur convenience for example 

ok setenv input-device ttya ( it should be here rsc-console for u now ) 
ok setenv ouput-device ttya 

also check other parameters like diag-out device .... to ensure that no redirection will go to rsc . 

finally 
ok reset-all 

----- 

there is another workaround but it is harder . 
power cycle the server and while it is booting when you see the front panel LEDs flashing together fast . immediatly click twice the power button this will redirect inp/outp to default which is ttya 
If you can login to the system via ssh/telnet you can use rscadm to 
reconfigure the rsc card. You might have to download the RSC software 
for Solaris, but if it's installed, you should find rscadm in 
/usr/platform/`uname -i`/rsc/ and be able to add a user using rscadm 
useradd command. 
Please tell me the Server Model. 

If you are able to telnet or ssh to the Server IP then you can change your rsc password from the OS prompt. Please follow the following steps; 
Login as root user: 
#cd /usr/platform/`uname -i`/rsc/ 
#./scadm userpassword <username> 
#./scadm resetrsc 
#cd / 
Then login to the rsc and try.

0 comments:

Post a Comment

 
Design by BABU | Dedicated to grandfather | welcome to BABU-UNIX-FORUM