Sunday, July 1, 2012

cron not executing commands (solaris 10)

/usr/sbin/cron is running, and is logging the commands in /var/cron/log, but they are not executed. This is on a i86pc server, on a sparc server it works ok (also solaris 10). The files in /etc/cron.d/ and /etc/default/cron are idential on both servers. What am i missing here??




do you have entries in /etc/cron.d/cron.allow or /etc/cron.d/cron.deny ?? 


/usr/sbin/cron is running, and is logging the commands in /var/cron/log, but they are not executed. This is on a i86pc server, on a sparc server it works ok (also solaris 10). The files in /etc/cron.d/ and /etc/default/cron are idential on both servers. What am i missing here?? 




NOTICE: This communication is intended only for the use of the individual or entity to which it is addressed and may contain information that is privileged, confidential and exempt from disclosure under applicable law. If the reader of this communication is not the intended recipient or the employee or agent responsible for delivering the communication, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify me immediately by replying to this email. 

REMINDER: The disclosure of medical information is strictly prohibited by federal regulation. Unauthorized release of medical information may result in administrative, civil and criminal sanctions.


hii, 

how did you edit the crontab file? 

i mean by # crontab -e 
or 
using vi editor??
Hi, 

can you try to run: 
svcs cron 
[should not return disabled, but if it is, run: 
pfexec svcadm enable cron 
to enable it] 

And if that is not case, can you check what: 
pfexec truss -f -p <pid of cron deamon> 
returns? 

It could be a path problem, try specifying the whole path to the executable 
you are running. 

0 comments:

Post a Comment

 
Design by BABU | Dedicated to grandfather | welcome to BABU-UNIX-FORUM