Tuesday, July 3, 2012

problem with user account (Solaris)

i have a problem with one of the user accout.(solaris 5.8) 

the user is trying to use a "find" command to search from his own 

directory,but the system returns "Permission Denied" 

>find ./ 
find: cannot open ./: Permission denied 

even man is not working 

>man ls 
getcwd: Permission denied 

I have tried the following 

1).profile changed 
2).profile copied from other box, but it still the same 
3).profile set to default ,but still the same 
4)shell has been changed ,but still the same 

The final option i have is, bounce the server.but i dont want to do 
What are the permissions on his home directory? What is his home directory? 

Bernie du Breuil -- (603) 381-6337 Home/Cell, 646-4108 Work 
United Valley Interfaith Project Another World is Possible
And what is the value of variable PATH 
echo $PATH 
hi , 
permissions are 

drwxr-xr-x 41 cgnos devel 4096 Apr 9 14:50 cgnos 

home directory redirected to 

/cms650/home/cgnos 

/cms650 -- mounted UFS file system have 81 % filled 

------ 
echo $PATH 

*# echo $PATH 
/usr/sbin:/usr/bin:/usr/sbin:/sbin:/usr/ccs/bi n:/usr/local/bin:/opt/VRTSvcs/bin:/usr/lib/ICAClien t:/usr/openwin/bin:/usr/local/sbin:/export/home/krr uther/bin 
* Check please the permitions of ~/.profile and related. But for me that's very strange because you have settings in PATH, so this should work. One idea, change the shell of the user and login again 
What happens when you su to that account yourself? Is the home directory being mounted using automount? Can the user cd to another directory? 
The message seems to be that he can determine is current directory. If he cd's to another directory can he then do the find or man commands? 
Does the user or a group the user is in, have execute permissions on all 
directories above the home directory? e.g. on /cms650 and /cms650/home 

0 comments:

Post a Comment

 
Design by BABU | Dedicated to grandfather | welcome to BABU-UNIX-FORUM