Sunday, July 1, 2012

Solaris 10 Virtual box unable to ping on LAN

Hi All, I have solaris 10 installed on my sun virtual box in my desktop. The virtual box uses a DHCP IP Iam able to ping to other computers in my network, but the other pc,s are not able to connect or ping to the virtual box. 




Set in /etc/defaultrouter IP address of your default gateway




What is the LAN configuration of the virtual box guest? If it is set to the 
default (NAT), then the guest IP address is not reachable from outside. The 
guest address looks like the host address to all outside systems. These are 
the available network modes in Virtual Box (from the documentation). If you 
want outside machines to be able to reach your guest, you will need to use 
"Bridged" mode: 

Network Address Translation (NAT) 

If all you want is to browse the Web, download files and view e-mail inside 
the guest, then this default mode should be sufficient for you, and you can 
safely skip the rest of this section. Please note that the ping utility does 
not work over NAT, and that there are certain limitations when using Windows 
file sharing (see Section 6.3.3, "NAT 
limitations"<ch06s03.html#nat-limitations>for details). 
Bridged networking 

This is for more advanced networking needs such as network simulations and 
running servers in a guest. When enabled, VirtualBox sets up an additional, 
software-based network interface on the host to which the virtual machine is 
connected. 
Internal networking 

This can be used to create a different kind of software-based network which 
is visible to selected virtual machines, but not to applications running on 
the host or to the outside world. 
Host-only networking 

This can be used to create a network containing the host and a set of 
virtual machines, without the need for the host's physical network 
interface. Instead, a virtual network interface (similar to a loopback 
interface) is created on the host, providing connectivity among virtual 
machines and the host.
Dear all thanks for the help. 

I was at last able to bring my virtual box on lan. 

Hi Brain as you have mentioned I have enabled bridge networking in my virtual box & 

As per Romeos comments I have added default gateway to /etc/defaultrouter. 

0 comments:

Post a Comment

 
Design by BABU | Dedicated to grandfather | welcome to BABU-UNIX-FORUM