Tuesday, July 3, 2012

Unix Zip utility with Password protection and Unable to Install GNUPG on Solaris 5.5

Hi, 
Was looking for the Unix Zip utility with Password protection of archive option. When i couldn't find one then i tried installing GNUPG Version:2.0.15 on Solaris 5.5. Did installed all the mandatory library files prior installing GNUPG. 
During the installation (./configure) end up in an error. Please find the log for the below. 

# ./configure 
checking for a BSD-compatible install... scripts/install-sh -c 
checking whether build environment is sane... yes 
checking for a thread-safe mkdir -p... scripts/install-sh -c -d 
checking for gawk... no 
checking for mawk... no 
checking for nawk... nawk 
checking whether make sets $(MAKE)... no 
checking build system type... sparc-sun-solaris2.5.1 
checking host system type... sparc-sun-solaris2.5.1 
configure: autobuild project... gnupg 
configure: autobuild revision... 2.0.15 
configure: autobuild hostname... xxxxxx 
configure: autobuild timestamp... 20100420-152311 
checking for style of include used by make... none 
checking for gcc... gcc 
checking for C compiler default output file name... 
configure: error: in `/var/tmp/gnupg-2.0.15': 
configure: error: C compiler cannot create executables 
See `config.log' for more details. 
# uname -a 
SunOS xxxxx 5.5.1 Generic_103640-34 sun4u sparc SUNW,Ultra-Enterprise 

# more config.log 
This file contains any messages produced by compilers while 
running configure, to aid debugging if configure makes a mistake. 

It was created by gnupg configure 2.0.15, which was 
generated by GNU Autoconf 2.64. Invocation command line was 

$ ./configure 

## --- ## 
## Platform. ## 
## --- ## 

hostname = xxxxxxx 
uname -m = sun4u 
uname -r = 5.5.1 
uname -s = SunOS 
uname -v = Generic_103640-34 

/usr/bin/uname -p = sparc 
/bin/uname -X = unknown 

/bin/arch = sun4 
/usr/bin/arch -k = sun4u 
/usr/convex/getsysinfo = unknown 
/usr/bin/hostinfo = unknown 
/bin/machine = unknown 
/usr/bin/oslevel = unknown 
/bin/universe = unknown 

PATH: /usr/sbin 
PATH: /usr/bin 
PATH: /usr/local/bin 
PATH: /var/tmp/gnupg-2.0.15 


## --- ## 
## Core tests. ## 
## --- ## 

configure:2733: checking for a BSD-compatible install 
configure:2801: result: scripts/install-sh -c 
configure:2812: checking whether build environment is sane 
configure:2849: result: yes 
configure:2874: checking for a thread-safe mkdir -p 
configure:2913: result: scripts/install-sh -c -d 
configure:2926: checking for gawk 
configure:2956: result: no 
configure:2926: checking for mawk 
configure:2956: result: no 
configure:2926: checking for nawk 
configure:2942: found /usr/bin/nawk 
configure:2953: result: nawk 
configure:2964: checking whether make sets $(MAKE) 
configure:2990: result: no 
configure:3172: checking build system type 
configure:3186: result: sparc-sun-solaris2.5.1 
configure:3206: checking host system type 
configure:3219: result: sparc-sun-solaris2.5.1 
configure:3243: autobuild project... gnupg 
configure:3245: autobuild revision... 2.0.15 
configure:3249: autobuild hostname... xxxxxxx 
configure:3258: autobuild timestamp... 20100420-152311 
configure:3275: checking for style of include used by make 
configure:3303: result: none 
configure:3373: checking for gcc 
configure:3389: found /usr/local/bin/gcc 
configure:3400: result: gcc 
configure:3629: checking for C compiler version 
configure:3638: gcc --version >&5 
gcc (GCC) 3.4.2 
Copyright (C) 2004 Free Software Foundation, Inc. 
This is free software; see the source for copying conditions. There is NO 
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. 

configure:3649: $? = 0 
configure:3638: gcc -v >&5 
Reading specs from /usr/local/lib/gcc/sparc-sun-solaris2.5.1/3.4.2/specs 
Configured with: ../configure --with-as=/usr/ccs/bin/as --with-ld=/usr/ccs/bin/ld --disable-nls --disable-libgcj --enable-languagesc,c++,obj : (reconfigured) ../configure --with-as=/usr/ccs/bin/as --with-ld=/usr/ccs/bin/ld --disable-nls --disable-libgcj --enable- 
languages=c,c++,objc 
Thread model: posix 
gcc version 3.4.2 
configure:3649: $? = 0 
configure:3638: gcc -V >&5 
gcc: `-V' option must have argument 
configure:3649: $? = 1 
configure:3638: gcc -qversion >&5 
gcc: unrecognized option `-qversion' 
gcc: no input files 
configure:3649: $? = 1 
configure:3671: checking for C compiler default output file name 
configure:3693: gcc conftest.c >&5 
In file included from conftest.c:11: 
/usr/local/lib/gcc/sparc-sun-solaris2.5.1/3.4.2/include/stdio.h:31:31: sys/feature_tests.h: No such file or directory 
/usr/local/lib/gcc/sparc-sun-solaris2.5.1/3.4.2/include/stdio.h:32:25: sys/va_list.h: No such file or directory 
configure:3697: $? = 1 
configure:3734: result: 
configure: failed program was: 
| /* confdefs.h */ 
| #define PACKAGE_NAME "gnupg" 
| #define PACKAGE_TARNAME "gnupg" 
| #define PACKAGE_VERSION "2.0.15" 
| #define PACKAGE_STRING "gnupg 2.0.15" 
| #define PACKAGE_BUGREPORT "http://bugs.gnupg.org
| #define PACKAGE_URL "" 
| #define PACKAGE "gnupg" 
| #define VERSION "2.0.15" 
| /* end confdefs.h. */ 
| #include <stdio.h> 
| int 
| main () 
| { 
| FILE *f = fopen ("conftest.out", "w"); 
| return ferror (f) || fclose (f) != 0; 

| ; 
| return 0; 
| } 
configure:3740: error: in `/var/tmp/gnupg-2.0.15': 
configure:3743: error: C compiler cannot create executables 
See `config.log' for more details.
i think this OS (Solaris 2.5) is too old for GnuPG 2.x. Try with this 
package (if this is suitable for you): 
http://www.sunfreeware.com/solaris_2.5_list.html#g nupg 
It worked, i have installed all the dependencies as adviced on the site you metioned and then it was all set. 

Once again i thank you for your quick response. 

0 comments:

Post a Comment

 
Design by BABU | Dedicated to grandfather | welcome to BABU-UNIX-FORUM