Monday, June 24, 2013

RedHat Linux commands

I`m using RedHat linux but when trying to run most of the commands they don`t respond - ifconfig, useradd,uid, and others. Can anyone tel me where did I go wrong? 
Note: I can ping my loop back address and it replies fine.




ls -ld /usr/sbin 
ls -ld /sbin 
and to check the PATH 
echo $PATH
on my path there`s nothing like usr/sbin/ but usr/kerberos/sbin - is this 
the one? but still when running ifconfig it doesn`t respond
Check in /sbin

What is the output of the "whoami" command?
Hi, 
test $PATH, i mean 
execute "echo $PATH" and you must see(if you are root user) 
.....:/sbin:/usr/sbin....
first chk this commands are available or not in ur server in /sbin. if not then install there rpm and use them. and if available but not working then remove there rpm and install them again. it will work.
Hi, 
Check with which command 
# which ifconfig 
/sbin/ifconfig <- ----- this is output 
Try typing the complete path and check if you get the output. 
# /sbin/ifconfig 
eth0 Link encap:Ethernet HWaddr 00:13:72:15:94:EA 
inet addr:192.168.1.5 Bcast:10.232.64.255 Mask:255.255.255.0 
inet6 addr: fe80::213:72ff:fe15:94ea/64 Scope:Link 


. output truncated 
check the same for /usr/sbin/useradd 
Hi Guys 
I`ve been struggling to run these commands even after re-installing the 
entire system (OS) but it still installed with the same problem. My concern 
is that when I load Enterprise Linux it works fine. any suggestion?

0 comments:

Post a Comment

 
Design by BABU | Dedicated to grandfather | welcome to BABU-UNIX-FORUM