Monday, December 9, 2013

metad client create: RPC: rpcbind failure

www.unixbabuforum.inI am working with Solaris 10 running SunCluster 3.1 using SVM. The problem is while I trying to create the diskset using command 
#metaset -s orads -a -h node1 node2 
node2 : metad client create: RPC: rpcbind failure 

I tried the same command at node2 with the same error output 
So somethings is amiss at node2. 
While I tried #metaset -s orads -a -h node1, it was successfully created. Then I tried to add node2 into this diskset, it failed too 
with same error. 

I had make sure both nodes have all the required rpc running 
#ps -ef | grep rpc 
node2 was rebooted with -r and rpcbind was restarted. There is not firewall in between nor TCP wrapper

www.unixbabuforum.inIt seems you already have something listening on the rpc port......and 
that is why the bind fails.......could you give the output of 
netstat -an 

www.unixbabuforum.inProblem Summary: During Solaris installation, the setting of a restricted network profile disables external access to network services that Sun Cluster functionality uses, ie: The RPC communication service, which is required for cluster communication 

Workaround: Restore external access to RPC communication. 

Perform the following commands to restore external access to RPC communication. 
# svccfgsvc:> select network/rpc/bindsvc:/network/rpc/bind> setprop config/local_only=falsesvc:/network/rpc/bind> quit# svcadm refresh network/rpc/bind:default# svcprop network/rpc/bind:default | grep local_only

0 comments:

Post a Comment

 
Design by BABU | Dedicated to grandfather | welcome to BABU-UNIX-FORUM