Tuesday, February 18, 2014

Error 500 Oops Cannot Change Directory /home/ftpuser in vsftpd

www.unixbabuforum.in Problem with my ftp server 
I run vsftpd in my redhat6 and config vsftpd.conf but when I want to login with my account I receive this error "error 500 oops cannot change directory /home/ftpuser" 
when I login with anonymous it work correctly what I have to do and which config is incorrect 

www.unixbabuforum.inPlease check /home/ftpuser folder permission and context switch. Run "ls 
-ldZ /home/ftpuser" and check output. Normally ftp folder carry 
"public_content_t" context. So please check whether folder have this 
context or not. You fixed it using "chcon -t" command. 

#chcon -t public_content_t folder_name 
www.unixbabuforum.inCheck your configuration file. You did not define good place for ftp users.


www.unixbabuforum.inCheck if selinux is enabled, it happened to me and it got me crazy

www.unixbabuforum.inTry this usr/sbin/setsebool ftp_home_dir=1 

www.unixbabuforum.inDoes the user's home directory even exist? Check /etc/passwd for the 
current home directory for the user and see what's set: 

1) # grep someuser /etc/passwd 
someuser:x:10001:2524::/var/www/someuser:/bin/bash 


2) File/Directory Permissions 


Be sure that the user that you are logging in as actually has permissions 
to be in the directory. This affects users that have home directories of 
/var/www/html because the execute bit normally isn't set for the world on 
/var/www or /var/www/html. Make sure that the appropriate permissions and 
ownerships are set, and this should help eliminate the issue. 

3) 
SELINUX: 

If SELINUX is rearing its ugly head on the server, this can be a problem. 
Check your current SELINUX status and disable it if necessary: 

# setenforce 
Enforcing 
# setenforce 0 

0 comments:

Post a Comment

 
Design by BABU | Dedicated to grandfather | welcome to BABU-UNIX-FORUM